Is EZFlora supposed to run this hot?

Comments and suggestions on the EZFlora irrigation controller

Moderator: Justin

gviliunas
Posts: 5
Joined: Thu Jul 03, 2008 2:03 pm

Is EZFlora supposed to run this hot?

Postby gviliunas » Mon Aug 17, 2009 6:02 pm

I received my new EZFlora from SHN a few weeks ago. I installed the unit and it has and continues to work flawlessly. Today, I noticed that the formerly white product label has turned brown and has begun to peal away from the case. I touched the unit and it felt uncomfortably hot. (Too hot to hold onto for long). The unit still works. Is it normal for the unit to run so hot or am I in danger of burning down my house?

Thanks for your help.

Greg

grif091
Posts: 996
Joined: Wed Jan 30, 2008 3:50 pm
Location: North Carolina

Re: Is EZFlora supposed to run this hot?

Postby grif091 » Mon Aug 17, 2009 7:27 pm

My EZFlora does not run that hot. If it is too hot to hold on to and the label is turning color I would suggest unplugging the unit and either email or call SHN support.

BLH
Posts: 207
Joined: Fri Jan 26, 2007 4:44 pm

Re: Is EZFlora supposed to run this hot?

Postby BLH » Tue Aug 18, 2009 1:08 pm

Someone on the Smarthome Forums. Was reporting one of theirs burned up
Melted the case and burned a hole through the rear of the case.
http://www.smarthome.com/forum/topic.asp?TOPIC_ID=5876

I would call Smarthome if you purchased it there or Simplehomenet if you bought it directly from them.


Return to “EZFlora”

Who is online

Users browsing this forum: No registered users and 1 guest